home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-dns / bind-tools-9.3.2 / bind-tools-9.3.2.ebuild < prev    next >
Text File  |  2006-05-01  |  1KB  |  53 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.3.2.ebuild,v 1.9 2006/04/25 02:26:18 tcort Exp $
  4.  
  5. inherit flag-o-matic
  6.  
  7. MY_P=${P//-tools}
  8. MY_P=${MY_P/_}
  9. S=${WORKDIR}/${MY_P}
  10. DESCRIPTION="bind tools: dig, nslookup, and host"
  11. HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
  12. SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV/_}/${MY_P}.tar.gz"
  13.  
  14. LICENSE="as-is"
  15. SLOT="0"
  16. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
  17. IUSE="ipv6"
  18.  
  19. DEPEND=""
  20.  
  21. src_compile() {
  22.     use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
  23.  
  24.     econf ${myconf} || die "Configure failed"
  25.  
  26.     export MAKEOPTS="${MAKEOPTS} -j1"
  27.  
  28.     cd ${S}/lib
  29.     emake || die "make failed in /lib"
  30.  
  31.     cd ${S}/bin/dig
  32.     emake || die "make failed in /bin/dig"
  33.  
  34.     cd ${S}/lib/lwres/
  35.     emake || die "make failed in /lib/lwres"
  36.  
  37.     cd ${S}/bin/nsupdate/
  38.     emake || die "make failed in /bin/nsupdate"
  39. }
  40.  
  41. src_install() {
  42.     dodoc README CHANGES FAQ
  43.  
  44.     cd ${S}/bin/dig
  45.     dobin dig host nslookup || die
  46.     doman dig.1 host.1 nslookup.1 || die
  47.  
  48.     cd ${S}/bin/nsupdate
  49.     dobin nsupdate || die
  50.     doman nsupdate.8 || die
  51.     dohtml nsupdate.html || die
  52. }
  53.